Minggu, 29 April 2012

Solve Error: Package: 1:php-eaccelerator-0.9.6.1-11.fc16.remi.i686 (@remi)


Tadi habis otak-atik repo, clean yum, config rpm,dll, panjang de ceritanya, yang jelas saat mau update fedora muncul pesan kaya gini :
Error: Package: 1:php-eaccelerator-0.9.6.1-11.fc16.remi.i686 (@remi)
Requires: php-common(x86-32) = 5.3.10
Removing: php-common-5.3.10-2.fc16.remi.i686 (@remi)
php-common(x86-32) = 5.3.10-2.fc16.remi
Updated By: php-common-5.4.1-1.fc16.remi.i686 (remi)
php-common(x86-32) = 5.4.1-1.fc16.remi
Available: php-common-5.3.8-3.fc16.i686 (fedora)
php-common(x86-32) = 5.3.8-3.fc16
Available: php-common-5.3.10-1.fc16.i686 (updates)
php-common(x86-32) = 5.3.10-1.fc16
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Karena di bawahnya ada pesan,

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Setelah di coba' tetap aja ga ngaruh..
Udah capek googling dan putus asa, akhinya saya nekat cara manual a.K.a oot dengan baca pesan errornya dimana, moga2 aja solve, begini caranya :
1. Error pertama,
Error: Package: 1:php-eaccelerator-0.9.6.1-11.fc16.remi.i686 (@remi)
Saya coba' install php-eaccelerator-0.9.6.1-11.fc16.remi.i686, ternyata udah ke install
2. Selanjutnya,
Removing: php-common-5.3.10-2.fc16.remi.i686 (@remi)
php-common(x86-32) = 5.3.10-2.fc16.remi
berarti remove php-common-5.3.10-2.fc16.remi.i686 :
# yum remove php-common-5.3.10-2.fc16.remi.i686
3. Next pesan,
Updated By: php-common-5.4.1-1.fc16.remi.i686 (remi)
php-common(x86-32) = 5.4.1-1.fc16.remi
php-common-5.4.1-1.fc16.remi.i686 adalah versi terbaru dari php-common-5.3.10-2.fc16.remi.i686 dan berhubung php-common-5.3.10-2.fc16.remi.i686 udah di remove, jadi install aja php-common-5.4.1-1.fc16.remi.i686 :
# yum php-common-5.4.1-1.fc16.remi.i686
4. Lanjut lagi,
Available: php-common-5.3.8-3.fc16.i686 (fedora)
php-common(x86-32) = 5.3.8-3.fc16
Available: php-common-5.3.10-1.fc16.i686 (updates)
php-common(x86-32) = 5.3.10-1.fc16
Dan ternyata package php-common-5.3.8-3.fc16.i686 & php-common-5.3.10-1.fc16.i686 tsb juga udah ke install..
5. Sekarang coba'de update, masalah tsb done! :)

2 komentar:

  1. yaya.. error message is the answer, :) kren..

    mau tanya kalau error blabla.so itu apa an yah, sory ini kasus lain waktu install MySQL :)

    BalasHapus